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Get a bird’s-eye-view of global
database properties on a
Domino server—fast.

Ytria databaseEZ lets you
manage NSF properties with
greater speed and precision. And
its troubleshooting tools help
you quickly find and fix database
issues on your servers.
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|datd:uaseEZ: Serverwide M5F Property Manager

You can launch databaseEZ from Lotus Notes, Domino Designer, or Domino Administrator with this toolbar.

The Databases panel lists the databases on
your server; tick checkboxes for the databases

you wish to show in the main grid. The main grid shows the databases on

your server along with their properties.

The Grid Data Composition panel lets you
choose which NSF properties to show in the
main grid.
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The Output panel (not shown) displays The Property Analyzer grid displays the
logs and errors.

(e.g. duplicate Replica IDs)

databases with issues or unusual properties.
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With databaseEZ you can
see and edit properties
for all the databases on a
server. Here’s how:

1.1

Analyze global NSF properties
in a grid: When you launch
databaseEZ, you’ll be prompted
to choose a server. Once a
server is selected, the left-

hand panel (Databases) lets

you click checkboxes for any

or all databases to show their
properties in the main grid.

1.1.1

Group, sort and filter global database
properties: In the main grid each
database is represented as a row and
each column shows a different NSF
property.

This grid interface lets you group by
column headers or perform sorting /
filtering operations.

1.1.1 Grouping by column headers: This example shows a multi-tiered grouping based on three NSF properties.
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f Test Databasze Y
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|#] Database File Type : Advanced Template (54)

test_one.nsf @ Database
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IZI Motices Of Change | Avis ... mphmp_noc.nsf
[#] Inherit from : StdDominol DAPSchema (1)
[+] Inherit from : StdNotes5055LAdmin (1)
[#] Inherit from : StdNotesCatalog (1)

Drag a column header here to group by that content.
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1.1.2 Summarized data: Yellow shading indicates properties retrieved using summarized data— they’re shown
nearly instantly.

1.1.2
Grid Data Composition 2 % See summarized data immediately or
load complete information: When you
EVNETRE A "R N- T . P . Jneny
first populate the grid, the majority of
Tab 1 - Database basics -

i properties will be shown immediately—
these are gathered using summarized
data. What’s more, the use of summarized
data lets you see many properties for
databases to which you have no access.
To show the remaining properties, click
Ctri+L or Edit>Load Complete
Database Information.

Tab 2 - Info
Tab 4 - Design
Bl Tab 6 - Full text
Database is full text indexed
Full text: last index time
Full text index size
Tab 7 - Advanced
B Replication Settings
Rermove Documents not modified in the last (days)

Deletion stub lifetime

Receive summary and 40KB of rich text only

1.1.3

Choose the properties to analyze with
the Grid Data Composition panel:
Roughly 100 database properties can
be shown in the main grid, but to make
things more visually manageable, only
22 are shown by default.

The Grid Data Composition panel lets

Send deletions made in this replica to other replica
Send changes in application title and catalog info t
Send changes in local security property to other rej
Temporarily disable replication for this replica
Scheduled replication pricrity for this replica
Replicate using schedule for priority applications
Deletion stub cutoff date

E Miscellaneous Information
Database ID

Legical Path ‘B . . .
Physical Path you customize the properties shown in
Last Fixup the grid, just tick the checkboxes then

Last Data Moedified

Last Non-Data Modified
Quota Limit

Quota Warning

Max Size

click ‘Apply.” You can also save your
preferences (or even multiple sets of
preferences) in this panel.

OEEOOEOOO0 OOoOOoOOoOoOoOoOoEO

1.1.3 The Grid Data Composition panel: Use checkboxes
to choose the properties to show in the main grid.
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With databaseEZ it’s
simple to mass-modify
database properties.
Here’s how:

2.1

Contextual menu options: The
right-click menu in databaseEZ
offers numerous options for
managing database properties
either individually or en-masse,
including the following:

2.1.1

Edit Database Basic Properties: This
option lets you manage properties that
correspond with the Basics tab of the
Database properties dialog in Lotus
Notes. (e.g. ‘Don’t allow URL open’ and
‘Disable background agents’).

B3 Design Properties

| CI%
Options
[] Allow design lacking
|&] List in Database Catalog
Categories
[] Show in ‘Open Application’ dislog
[ Include in mutti-databass indexing
[l Do not mark modfied documernts as unread
|| Mark parent note on reply or forward

Inheritance
[ Inherit design from master template
Template

| Refresh design on admin server only

Database file is 3 master template

Templste ] [-No Change -]

List as advanced template in "New Application’ dialog

[] Copy profile documents with design

[ Single copy template
Multilingual Options
[ Muttiingual databass

Defautt language [-Empty-]
Default region
Default sort order ['E"'IDTY'i

Unicode standard sorting

Other ontion:

r
B Advanced Properties

B

s
B7 Basic Properties

Title D [;i\lo Ch;nge -I’
Server | Demo2/Demo2.

Flename. [ -No Change - |

[] Use JavaScript when generating pages
W [ Require S5L connection

Dont allow. URL open:

["] Enable enhanced HTML generation

[] Disable background agents for this databass
Allow use of stored forms in this datsbase
& Display images after loading

Unread Mark Options

[”] Dont maintain unread marks

Replicate unread marks:

(#) Never | Clustered servers only || Al servers

Advanced Options -

pation is

[ Optimize documert table map

[7] Dont ovenwrite free space

[C] Maintain LastAccessed property

[ Disable transaction logging

[7] Dont support specialized respanse hierarchy
[ Use LZ1 compression for attachmerts

Use Doming Attachment and Object Service
|| Dont allow headiine monitoring

[] Mllow more fields in database

Limit what will be sent to other replicas —
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|| Send changes in application tile and catalog info to other replicas
[] Send changes in local securty property to other replicas
- Special replication limitations
Temporariy disable replication for this replica
Set scheduled replication priority for this replica
) Low (%] Medium (_! High

This replica includes deletion stubs for all documents deleted since
[ [-Ne Change -] Date Picker. .

[] Allow docyment locking =3 it
low cor| 8% Miscellaneous Properties
O i e esprse Tred Hitory
[T Inhertt op allow simple search
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[7] Falder Ref ] Activity is corfidential ress document data
[F] Database| e automatic updating of views
- Remove documents from the replica le export of view data
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[T Receive summary and 40KE of rich tex only B ciee e g e

OK Cancel

s in $UpdatedBy fields 25
s in SRevisions fields  [7] [NC]

[0k A

You can mass-edit global NSF proper-
ties, see 2.1.1 to 2.1.4 for more.

2.1.2

Edit Database Design Properties:
This option lets you manage properties
that correspond with the Database
Design tab of the Database properties
dialog in Lotus Notes. (e.g. ‘Show in Open
Application dialog’ and ‘Template name’).

2.1.3

Edit Database Advanced Properties:
This option lets you manage properties
that correspond with the Advanced tab
of the Database properties dialog in
Lotus Notes. (e.g. ‘Don’t maintain unread
marks’ and ‘Allow soft deletions’).

2.1.4

Edit Database Miscellaneous
Properties: This option lets you manage
properties related to User Activity and
Replication Settings. (e.g. ‘Record user
activity’ and ‘Temporarily disable
replication’).

r!ﬁ Replace using regular expression results u‘
|CurrentTempIate Mame |NewTempIate Mame
StdR4AgentlLog ArchiveR4AgentLog
StdActivity TrendsDatabase ArchiveActivity TrendsDatabase
StdRS0Archivelog ArchiveR50ArchiveLog
StdR4Billing ArchiveR4Billing
StdR4AdminRequests ArchiveR4AdminRequests

StdMotesCatalog ArchiveNotesCatalog

StdMetes5055LAUth ArchiveMNotes5055LAuth
StdMotesCertificationLog ArchiveNotesCertificationLog

L StdCertPubRequests ArchiveCertPubRequests
StdCertificateRequests ArchiveCertificateRequests I

StdR4ClusterDirectory
StdR4ClusterAnalysis
StdMotes5055L Admin
StdMasterAddressBookd 5

ArchiveRd4 ClusterDirectory
ArchiveR4ClusterAnalysis
ArchiveNotes5055LAdmin
ArchiveMasterAddressBookd.5

StdR4DBARalysis ArchiveR4DBARalysis
StdDbDirMan ArchiveDbDirMan
StdR4Databaselib ArchiveR4Databaselib

| StdMotesDecormmissionServer  ArchiveNotesDecommissionSe ™ ||
4 I | »

Waming: This replacement will lead to one-or-more template sharing the
same name. Domino servers require template names to be unique so you
won't be able to save this change to the server.

Templates with duplicate names are highlighted in red.

If you click "Replace Unique’ duplicate template names will not be applied
Click 'Replace All'to disregard this waming and replace all names

Replace Al

Note:

Databases changed in the grid are
marked with a ‘pencil’ icon. However,
changes won’t be written to the server
until you click Server>Apply Changes
(Ctrl+S) or Right-Click>Apply
Changes to Selected.

Also, some properties require that you
perform a compact operation after editing
(i.e. “Don’t Maintain unread marks”;
“Optimize Document Table Map”; “Quota
Limit”; “Don’t support specialized
response hierarchy”; and “Compress
database design”). If the compact step is
omitted, changes won’t be applied.

2.1.5

Edit Replia ID/ Generate Replica
ID(s): You can right-click any database
in the grid to change its Replica ID.

You can also right-click multiple selected
databases and generate new replica IDs
for them.

2.1.6

Export IND File: This allows you to
export an IND file with the names of all the
databases currently selected in the grid.

2.1.7

Open with...aclEZ/agentEZ/
designPropEZ/scanEZ/signEZ: These
options let you open selected databases

in other Ytria tools.
Note:

Like all Ytria software, databaseEZ is fully
compliant with Lotus Notes security. You
must have sufficient access in order to
make changes to databases.
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Load Complete Database information Ctrl+L
I Revert to Summarized Information Ctrl+U
Edit Database Basics Properties Ctrl+1
Edit Database Design Properties Ctrl+2
Edit Database Advanced Properties Ctrl+3
Edit Database Miscellaneous Properties  Ctrl+4

Edit Template Name(s)
Edit Replica ID

Generate Replica IDVs)
Generate Database [D(s)
Export IND file

Apply Changes to Selected
Open with aclEZ

Open with agentEZ

Open with designPropEZ
Open with scanEZ

Open with signEZ
Sign/Audit with Another ID {with signEZ)...
Open in Designer

Open in Motes Client

Delete databasels)

The right-click menu in databaseEZ’s main grid.

2.1.8

Sign/Audit with Another ID (with
signEZ): This lets you directly sign

or audit the design elements for any
selected database. This option requires
that you also own Ytria signEZ.

2.1.9

Open in Designer/Open in Notes
Client: These options allow you to open
selected databases in either the Notes
client or Domino Designer.

2.1.10

Delete database(s): You can use this
to delete any databases you have
selected in the grid.

2.2

Full Access Administration:
Like all other Ytria tools,
databaseEZ supports Full Access
Administration. If you're listed as
a Full Access Administrator on the
server you can enable (or disable)
this feature by clicking Options>
Full Access Administration.

Options i Help

*+ | Read Database Immediately upon Selection
Read Database only when 'Apply' Button is Clicked
Database Files 4
Log Type L4
Automatically Load Detailed Agent Information
Force Designer Access to Edit Agents

#+ | Use Notes API Security

Full Access Administration... m

With databaseEZ you
can scan a server for
issues or aberrations,
here’s how:

3.1

The Serverwide Property
Analyzer: This utility lets you
find databases with unusual

or problematic properties; to
launch it, click Tools>Property
Analyzer. The following property
analysis options are available:

3.1.1
Template name duplicates: This will flag
any identical template names.

3.1.2
Replica ID duplicates: This will find
databases that share the same Replica ID.

3.1.3

Inherits from a template that does
not exist: This will reveal databases
that are set to inherit from a nonexistent
template.

3.14

Database has a specific percentage
of quota remaining (%): This will reveal
all databases that have reached or
exceeded a given percentage of their
size quota.

3.1.5

No data change since n days: Shows
any databases where document data
has not changed since before the
given number of days.

3.1.6

Design changed within last n days:
Shows database where the design has
changed within the number of days
given.

3.1.7

Database has reached a specific
size: Displays databases that match or
exceed the size given.

===

 Chosse which properties you wart to analyse - —

- _
B2 Serverwide property analyzer 2

l Replica ID duplicates

Inherit from a template that doss not exist

|| | [ Database has a specific percertage of quota remaining 90 %
[ No data changed since 1] days
[”] Design changed within last 60D days
Database has reached a specifc size o] me

.
[”] Launch the analyzer on startup of datahassEZ

| Savesetingsandnnandyzer | | Saveseftings | | Caneel |

L

3.1 The Serverwide Property Analyzer dialog: You can
scan a Domino server for databases that meet the
conditions entered here.

3.1.8

Launch Analyzer on startup of
databaseEZ: By checking this option
the Property Analyzer dialog will appear
each time you open databaseEZ.

3.1.9

Save Settings and Run Analyzer: This
performs the Property Analyzer scan on
all databases shown in the grid and also
saves your settings.

3.1.10

Save Settings: Saves property settings
for the next time you open the Property
Analyzer.
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3.2 The Property Analyzer Results grid: Databases
found using a Serverwide Property Analyzer scan are
shown in this grid.

3.2

Property Analyzer grid results:
If you click Save Settings and
Run Analyzer, any databases
that match the entered criteria
will appear in the Property
Analyzer grid at the bottom of
the databaseEZ window. From
here you can group, sort or filter
column headers. You can also
right-click databases to select
them in the main grid.
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